Scroll

Zugriff auf CaseWare Cloud für ältere und nicht mehr unterstützte Webbrowser wird deaktiviert

Updated:
Jun 22nd, 2020

Kurz nach dem Release von CaseWare Cloud 31 wird CaseWare den Zugriff auf CaseWare Cloud durch alte und nicht mehr unterstützte Webbrowser sperren. Diese alten und nicht mehr unterstützten Browser verwenden veraltete Verschlüsselungsprotokolle - TLS Version 1.0 und v1.1.

Der PCI Security Standards Council empfiehlt allen Unternehmen den von diesem Forum ausgegebenen Best Practices zu folgen und SSL/TLS auf TLS v1.2 oder höher zu migrieren. Diese Änderung wird zwingend von allen Anbietern umgesetzt, um sichere Verbindungen zu gewährleisten, die Ihre sensiblen Daten verschlüsseln und schützen und sie so vor vorsätzlichen Schäden oder böswilligem Zugriff bewahren. CaseWare wird diese Empfehlung für alle eingehenden Verbindungen übernehmen.

Was ist TLS?

TLS steht für „Transport Layer Security“. Es handelt sich um ein Protokoll, das für die Einhaltung von Datenschutzrichtlinien und Datenintegrität zwischen zwei miteinander kommunizierenden Anwendungen sorgt. Es ist das heute am weitesten verbreitete Sicherheitsprotokoll und wird für Webbrowser und andere Anwendungen eingesetzt, bei denen es notwendig ist, Daten sicher über ein Netzwerk auszutauschen. TLS stellt über Verschlüsselung und die Überprüfung der Endpunktidentität sicher, dass es sich bei der Verbindung zu einem Remoteendpunkt auch um den vorgesehenen Endpunkt handelt. Die verfügbaren TLS Versionen sind TLS 1.0, 1.1, 1.2 und 1.3.

Wer ist betroffen?

Alle CaseWare Cloud Anwender (Mitarbeiter und Kontakte) sowie Hybrid Cloud Kunden, die mit alten und nicht mehr unterstützten Webbrowsern auf CaseWare Produkte zugreifen, sind betroffen. Eine vollständige Liste der betroffenen Webbrowser finden Sie im Abschnitt „Kompatibilität der Internetbrowser“ unten.

Überprüfen Sie, ob Sie einen Browser einsetzen, der nicht mehr unterstützt wird:

  1. Verwenden Sie die Anwendung TLS 1.2 Browser Test, um Ihren Browser zu prüfen.

  2. Wenn Ihr Browser aktualisiert werden muss – also nicht 1.2 oder höher angezeigt wird – finden Sie auf der folgenden Seite die Schritte, die durchzuführen sind, um TLS 1.2 oder höher zu aktivieren: Enabling TLS 1.1 and TLS 1.2 on web browsers (in Englisch).

Verhalten, wenn Aktualisierung des Browsers nicht durchgeführt wird

Anwender werden nicht mehr auf CaseWare Cloud zugreifen können, solange deren Browser oder Browser-Einstellungen nicht entsprechend den unten aufgeführten Kompatibilitätsrichtlinien aktualisiert wurden.

  1. CaseWare Cloud Anwender
    Anwender, die keinen kompatiblen Browser verwenden, erhalten eine Fehlermeldung auf der CaseWare Cloud Anmeldeseite und werden keine Verbindung zum Server aufbauen können. Sobald der Browser oder die Browser-Einstellungen aktualisiert wurden, kann der Anwender die Seite aktualisieren, um wieder auf die Anmeldeseite zu gelangen.

  2. Working Papers Anwender mit Cloud-Integration für SmartSync
    Anwender, die keinen kompatiblen Browser verwenden und die folgenden Versionen einsetzen:

    1. Working Papers 2018 oder höher
      • erhalten eine Fehlermeldung, wenn sie sich aus Working Papers heraus mit der CaseWare Cloud Anmeldeseite verbinden.

      • werden keine Dateien in der Registerkarte SmartSync Server im Menü Datei – Öffnen sehen oder aufrufen können,

      • werden nicht in der Lage sein, sich mit dem Server zu verbinden, um Änderungen ihrer lokalen Sync-Kopie zu synchronisieren. Im rechten unteren Bildschirmbereich zeigt eine Meldung an, dass die Datei offline ist.

    2. Working Papers 2017 oder niedriger
      • werden keine Dateien in der Registerkarte SmartSync Server im Menü Datei – Öffnen sehen oder aufrufen können,

      • werden nicht in der Lage sein, sich mit dem Server zu verbinden, um Änderungen ihrer lokalen Sync-Kopie zu synchronisieren. Im rechten unteren Bildschirmbereich zeigt eine Meldung an, dass die Datei offline ist.

Sobald der Browser oder die Browser-Einstellungen aktualisiert wurden, kehren die Working Papers Dateien in ihren Online-Status zurück, wenn eine Internetverbindung besteht. Anwender müssen sich ggf. erneut bei CaseWare Cloud anmelden, sofern die Konfiguration der Firmeneinstellungen eine tägliche Anmeldung bei CaseWare Cloud verlangt.

Kompatibilität der Internetbrowser

Wie in den Systemvoraussetzungen (in Englisch) von CaseWare Cloud beschrieben, werden folgende Browser unterstützt:

  • Google Chrome (empfohlen)
  • Mozilla Firefox
  • Microsoft Edge

Überprüfen Sie mithilfe dieser Anwendung, ob Ihr Browser TLS 1.2 oder höher unterstützt. Falls Ihr Browser aktualisiert werden muss (also nicht 1.2 oder höher angezeigt wird), finden Sie auf dieser Webseite die Schritte, wie TLS 1.2 oder höher aktiviert werden kann (in Englisch).

Lesen Sie die folgenden Kompatibilitätsrichtlinien:

Browser

Hinweise zur Kompatibilität

Google Chrome
Kompatibel mit der aktuellsten Version unabhängig vom Betriebssystem.
Google Chrome 38 und höher Kompatibel mit TLS 1.2 
Google Chrome 30 bis 37 Kompatibel, wenn auf folgenden Betriebssystemen ausgeführt:

  • Kompatibel, wenn der Browser auf Windows XP SP3, Vista oder neuer (Desktop),
  • OS X 10.6 (Snow Leopard) oder neuer (Desktop) oder
  • Android 2.3 (Gingerbread) oder neuer (mobil) ausgeführt wird.
Google Chrome 29 und niedriger Nicht kompatibel mit TLS 1.2
Mozilla Firefox
Kompatibel mit der aktuellsten Version unabhängig vom Betriebssystem.
Firefox 27 und höher Standardmäßig kompatibel mit TLS 1.2.
Firefox 24 bis 26 Kompatibel, aber nicht standardmäßig.

Verwenden Sie „about:config“, um TLS 1.1 oder TLS 1.2 zu aktivieren, indem Sie den Wert security.tls.version.max config für TLS 1.1 auf 2 oder für TLS 1.2 auf 3 setzen.

Firefox 23 und niedriger Nicht kompatibel mit TLS 1.2 
Microsoft Edge
Microsoft Edge Standardmäßig kompatibel mit TLS 1.2.

Nicht offiziell von CaseWare Cloud unterstützt 

Google Android OS Browser
Android 5.0 (Lollipop) und höher Kompatibel mit TLS 1.2 
Android 4.4 (KitKat) bis 4.4.4 Könnte mit TLS 1.2 oder höher kompatibel sein. Einige Geräte mit Android 4.4.x unterstützen TLS 1.2 jedoch nicht.
Android 4.3 (Jelly Bean) und niedriger Nicht kompatibel mit TLS 1.2
Apple Safari
Desktop Safari Versionen 7 und höher für OS X 10.9 (Mavericks) und höher Standardmäßig kompatibel mit TLS 1.2
Desktop Safari Versionen 6 und niedriger für OS X 10.8 (Mountain Lion) und niedriger Nicht kompatibel mit TLS 1.1 oder höherer Verschlüsselung
Mobile Safari Versionen 5 und höher für iOS 5 und höher Standardmäßig kompatibel mit TLS 1.2
Mobile Safari für iOS 4 und niedriger Nicht kompatibel mit TLS 1.2 

Get in touch with your local Distributor